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Introduction
IFC – Industry Foundation Classes - is a neutral file format that 
makes it possible to exchange information between different CAD 
systems and other systems in the building and facility management 
sectors. The IFC format is ISO-certified and can be integrated into 
any existing quality assurance polices your office may have. IFC is 
developed in part by the IAI – the International Alliance for 
Interoperability. Today there are over 600 members with 12 chapters 
around the world. For more information, see: 
www.iai-international.org.

Graphisoft has played an active role within the  IAI organization and 
supports the latest IFC standard, IFC 2x3. The IFC standard enables 
ArchiCAD to communicate with other disciplines within the context 
of the building model, and to coordinate a building project entirely in 
3D. The building model can also be exported back to literally 
hundreds of other systems that support IFC.

The BIM, or “Building information model,”  is one of the biggest 
advances in the building industry’s working methods since the 
introduction of CAD software. The gap between CAD software and 
hardware has closed dramatically the last few years, making it 
economically viable to coordinate projects in 3D. 

BIM is NOT synonymous with 3D projects. Three-dimensional 
geometric representation is only one part of the digital deliverables. A 
project includes non-graphical information, such as calculations that 
are used in surveying, facility management and energy calculation.

But the first and perhaps most important step toward a full BIM 
working method is to model and coordinate in 3D. Architects, 
engineers, HVAC contractors and clients all gain from using a BIM 
model. A BIM model can gradually encompass information used by 
facility managers , accountants, and environmental regulators. Even in 
a later stage of  the model's life cycle, BIM is useful for real estate 
agents, security companies, fire brigades and cleaning contractors.
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A prerequisite for a successful BIM project is that intelligent 
information can be exchanged between different software and even 
operating systems, throughout the stages of the building process. This 
interoperability demands a neutral file format with an open standard 
that supports different systems. IFC is such a system, enabling us to 
synchronize building models between the disciplines much more 
easily. With its user-friendly interface and high degree of 
customizability, the IFC add-on for ArchiCAD enables users to 
communicate in an efficient way, to focus on the needed elements 
and to locate any errors in design development.
This Guide has been created to provide ArchiCAD users an insight 
into the IFC standard and how it works in ArchiCAD. The IFC 
version discussed in this Guide is 2x3 for Graphisoft's ArchiCAD 12.

Installation of IFC 2X3 in 
ArchiCAD 12
The IFC 2X3 add-on installed with ArchiCAD 12 is located in the 
Add-ons/Import-Export folder in the ArchiCAD program folder. 
For the latest beta and final releases of the IFC add-on, see 
Graphisoft’s web site: 
http://www.graphisoft.com/support/ifc/downloads/public/
Please note that IFC 2X3 is the default add-on for ArchiCAD 12. 
IFC 2X2 can be downloaded through the Goodies page, available 
through ArchiCAD's Help menu. 

New Features in IFC 2X3 
Add-On for ArchiCAD 12
1) New IFC tree interface
2) New IFC section in Settings dialog boxes
3) Handling of all standard IFC PSets
4) Handling of all IFC types and properties with simple values
5) Handling of complex properties
6) Custom property creation
7) Merge partial IFC model to ArchiCAD plan
8) Merge partial ArchiCAD model to IFC model (not yet available in 

released version)
9) Partial Structure Settings
10) User interface for generating and editing the configuration XML 

file for PSet mapping
11) Option to display localized IFC keywords on user interface
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Helpful Hints in Planning 
an IFC Project
1) First, decide which IFC version (e.g. 2x2 versus 2x3) should be 

used. Ensure that your partners, who will be using the IFC file, 
have compatible programs enabling them to read your file 
version.

2) Next, consider what type of information should be exported to 
the different disciplines. Different disciplines will require 
different parts of the total informational flow of an IFC-project. 
For example, building engineers will want the load-bearing parts 
of the building (see Structural-Related IFC Features later in this 
document), while an HVAC consultant will need a richer model 
with more internal information. Once these issues are decided, 
the IFC 2X3 Add-On’s interface enables you to filter the building 
information model accordingly before exporting it.

3) It is good practice, in a newly started project, to start with a 
simple model for export, to verify that all of the required 
information is exported and imported correctly into and from 
each discipline’s respective program. Once this simple model has 
been exported and read correctly, then more information can be 
added to the model successively.

4) When exporting an IFC model, it is good practice to check the 
IFC model in a IFC viewer. There are many free IFC viewers on 
the market that can be readily downloaded.:
Solibri Model Viewer: http://www.solibri.com
DDS IFC Viewer: http://www.dds-cad.net/
Nemetschek IFC Viewer: http://www.nemetschek.co.uk/ifc
Additional information can be found at the following Wiki 
address:
http://www.ifcwiki.org/index.php/Free_Software

IFC Interface in ArchiCAD
Menu Commands
Once the Add-On is installed, the two IFC settings dialog boxes 
(“Tree View” and “Options”) can be accessed from: File > File 
Special > IFC 2x3.

IFC Panel in Tool Settings
Even after you have loaded the IFC add-on to ArchiCAD 12, the IFC 
panel in each Tool Settings dialog box is hidden by default. 
To show the IFC panels, go to Options > Work Environment, and 
open the Tool Settings Dialog Boxes page, as shown below.
For each tool, click the eye icon of the IfC 2X3 panel to make it 
visible.
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The IFC panel can be shown in the Settings dialog boxes of the 
following ArchiCAD tools: walls, columns, beams, doors, windows, 
objects, stairs, slabs, roofs, corner windows, skylight, lamp curtain 
wall and the zone.

In each such Settings dialog box, the IFC Panel looks like this:
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Basic IFC Terms and 
Definitions
GUID
Globally unique ID. A GUID is a string assigned to each element, 
both in ArchiCAD and in IFC. As its name indicates, a GUID 
enables a program to identify and differentiate elements, since each 
element has been assigned a unique ID.
An element's GUID in ArchiCAD is not the same as its GUID in 
IFC.

IFC Entity
Project information from ArchiCAD saved in IFC is represented as a 
set of entities - such as elements, materials, and their relationships. 
Each entity (for example, an IFC Wall) includes a fixed number of 
attributes, plus any number of additional properties.

Attribute
An attribute helps to define an IFC Entity.
Each entity (for example, an IFC Wall) has Attributes that include its 
name, description and GUID (called a Tag in the IFC panel’s 
Attribute list).
Each Attribute has a Name, Value, and Type. For example, the Wall 
whose Settings are shown here has the following attributes: GlobalID, 
Name, Description, Object Type, and Tag.
By default, few attributes are checked, to minimize IFC file size. 
Check any additional attributes to include them in the IFC export. Property

Properties are additional parameters assigned to an IFC entity. 
Properties are grouped into Property sets (Psets); these are listed as 
drop-down items in the element’s IFC Panel. Click on the Pset name 
to display the parameters it contains. 

By default, most IFC entities include standard Property Sets. In 
ArchiCAD’s Element Settings dialog boxes, you can create custom 
properties and custom property sets too. (See Create New Property.)
IFC 2x3 Reference Guide for ArchiCAD 12 5



ArchiCAD IFC 2x3 Guide
As with attributes, few of the properties are checked by default, to 
minimize IFC file size. Check any additional properties to include 
them in the IFC export.
For an example, see Enable Load-Bearing Property.

Create New Property

To create a new IFC Property for an ArchiCAD element, click the 
Create New Property button on the IFC 2X3 panel of the element’s 
Settings dialog box. (The same button is available in the IFC Tree 
View dialog box.) 

First, create a custom Property Set (use the Name of Property Set 
field). Then type in the name of the new custom Property. Use the 
drop-down menus to adjust the new property’s Property Type and 
Value Type.

Note: To avoid errors, do not use the standard PSET_ prefix 
when giving a name to your custom Property Sets.

To add another new property to the custom property set, first select 
the property set from the first pop-up (Existing Property Set), then 
add another new custom property.

IFC Element Type

The Element Type concept enables you to add yet another layer of 
classification to some IFC entities. Entities belonging to a particular 
Element Type can share certain properties. If you change one 
Element Type property, that property will be modified for all entities 
belonging to that Element Type.

For example, by default, both a Lamp object and an Air Diffuser are 
considered to be a Flow Terminal in IFC, as shown in this Lamp’s 
dialog box:

However, you can more narrowly classify the Lamp by its Element 
Type in addition to its generic IFC element name. At the top of the 
Lamp’s IFC panel, switch the pop-up from “Element Attributes and 
Properties” to “Element Type Attributes and Properties.”

Now the Lamp Settings shows the attributes and properties of its 
Type (Light Fixture) rather than being considered generically as a 
Flow Terminal. Here, you can check the attributes and parameters 
which you would like to export by Type, to enable a more exact 
classification of the element in IFC.
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Save and Apply IFC 
Parameters in ArchiCAD
To maximize performance, the workflow for saving and applying IFC 
parameters for ArchiCAD elements differs from standard element 
creation in ArchiCAD. It is recommended that you use the following 
workflow:
1) Adjust attributes and properties in each element’s Default 

Settings dialog box (IFC 2X3 Panel).
2) Save the adjusted Default Settings as a Favorite. Create as many 

Favorites for each element as you need (e.g. “IFC Internal Wall;” 
“IFC External Wall”).

3) Place elements as needed to construct the model in ArchiCAD.
4) Select the elements to which you will apply IFC parameters. 
5) In the Selection Settings dialog box, click Favorites, then apply 

the appropriate Favorite Settings to the selected elements.
Note: You cannot use the pipette shortcut (pick-up/transfer 
parameters) to transfer IFC information from one wall element 
to another. The recommended way to apply IPC parameters to 
ArchiCAD elements is to Apply Favorites, as described above.

IFC Options
To set options for import, merge and other IFC configuration 
settings, go to File > File Special > IFC 2X3 > Options. 

This dialog box also appears automatically every time you execute the 
File > Save As *.ifc command. (If you do not want to this dialog box 
to appear after every Save As IFC command, uncheck the 
corresponding box in the Miscellaneous Options page of this dialog 
box.)
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There are seven pages of options accessible from this dialog box. Use 
the drop-down list, or the Previous/Next buttons to navigate among 
them.
At the bottom of any page, you can click Restore Default to discard 
your options changes and return to the default settings.

Below are explanations and recommendations for export settings for 
IFC2x3:

Units Options

Define the units (Length, Angle, Area and Volume) for an IFC 
project when exporting from ArchiCAD.

Note: Units are only set when exporting an IFC model from 
ArchiCAD, not when importing an IFC model.

Export Options

Use this page to filter elements in the ArchiCAD database for export.

Geometric Representation
In IFC, a “site” is a defined point with exact geographical 
coordinates. Usually, the site has no geometry (the default setting for 
IFCSite is “Site with no geometry.”)

Alternatively, you can add geometry to the IFCSite by exporting 
ArchiCAD mesh(es), or GDL objects you have specifically created as 
“Site objects”, or all of the above (“Meshes and site objects.”)
To save a site object (for example, if you have created a site geometry 
from a combination of meshes and slabs), you must save it as 
IFC_SITE.GSM. (Select the mesh/slab elements in ArchiCAD, then 
use the File > Libraries and Objects > Save Selection As... 
command.)

Note: Capital letters must be used.
If you are exporting any of these kinds of site geometry, the next 
pop-up is activated.
• Surface based format or Geometric set format: use these 

options if you want to reduce the overall size of the IFC model 
• BREP: A BREP (boundary representation) is a geometric object 

that is specified by its boundary faces. This option will give you 
the most detailed geometric representation, but may also include 
a lot of unwanted information. Its usefulness is generally limited 
to visualization. Use this option only if you want a richly detailed 
model.
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Object/Lamp and Door/Window as BREP

It is recommended to leave these boxes checked. For these elements, 
the additional detail provided by BREP is usually an advantage 
despite the larger file size.

Export Element

By default, all visible elements will be exported. To change this setting 
to any of the other listed options, execute the File > Save As ... 
command, and choose the IFC file format. The Options dialog box 
appears, in which this control is now active. 

Note: If the Options dialog box does not appear, go to the 
Miscellaneous Options page of this dialog box and make sure the 
corresponding box is checked.

Follow Partial Structure Setting
As of ArchiCAD 12, composite and complex (profile) elements can 
be displayed using partial structure settings: either Core Only, 
Without Finishes, or Entire Structure. Check this box to take 
ArchiCAD’s Partial Structure settings into account when exporting to 
IFC. (If you leave this box unchecked, all composite and complex 
elements will be exported as Entire Structures.)
See also Layer Settings and Partial Structure Display.

Default Door/Window Type
It is recommended to leave this box unchecked.
Checking this box will classify all doors and windows as a single, 
default Type, narrowing the range of their parameters. IFC doors and 
windows are not affected by this setting.

Area/Volume Calculation
Check this box to include Area and Volume calculations in the IFC 
model (for example, if you will need quantity takeoffs for cost 
estimation purposes.)
See IFC Settings for Quantity Takeoff.

Extended Properties
If the IFC project is expected to do a "round trip" (i.e. you will merge 
it back into ArchiCAD), then it is advantageous to use this setting 
when exporting the model to IFC. This option will enable ArchiCAD 
to try to map the original object when you import the IFC model 
again. 

Note: Choosing this option will significantly increase the IFC file 
size.

Save Space boundaries
Check this box only if you are using the IFC model in thermal 
calculation applications (e.g. with Energy Plus). Using this option 
increases processing time and file size dramatically.
Space boundaries define the logical connection between ifcSpaces 
(zones in ArchiCAD) and the building elements (e.g. walls and slabs) 
that enclose them.
See IFC Settings for Thermal Calculation.

Save Space containment 
Check this box if you are using the IFC model in facility management 
applications.
Space containment defines the relationship between ifcSpace (zones 
in ArchiCAD) and IFC Furnishing or Distribution elements within 
the space.

2D Elements
IFC2x3 is able to save text, labels, symbols and fills.
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Custom Property Set Options

Use these controls if you want to include all or selected ArchiCAD 
Library Part parameters when exporting to IFC.

Note: If you do not load or generate a Property Set 
Configuration file here, parameters of ArchiCAD Library Parts 
will not be exported to IFC.

To export all Library Part parameters (regardless of whether these 
LibParts have been placed in the model) with their default mapping 
definitions, check the Enable box.
Then do one of the following:
• either click Browse to load any property configuration file (.xml), 
• or click Generate Configuration File to generate a default .xml 

file with mapping definitions based on the currently loaded 
library.

Edit Configuration File: To narrow the set of parameters, or to 
rename any of them, click this button to open an editing window.

At the top of the window, check/uncheck the Library Part names to 
limit the parameters to be exported. 
For each selected Library Part name, its parameters are shown in the 
bottom half of the window, with their default IFC parameters. As 
needed, edit any of the Property names. The properties will be 
exported to IFC under the names you enter here.
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Exterior Options

Use these options to optionally classify Walls as either “Interior” or 
“Exterior” by defining ArchiCAD layers for them. 

Person and Organization Options

Use this page to enter general information about the project owner 
and organization. This information will serve as additional properties 
of the IFC element. 

Import Options

These options affect the Merge function, used to merge an IFC file 
into an ArchiCAD project. (See Merge IFC to ArchiCAD.)
Use these options if you wish to differentiate IFC file elements from 
the original ArchiCAD elements by placing them onto a separate 
layer. To do this, check the Merge to Special Layer box. You then 
have further options: to lock these merged elements; and to assign a 
name to the Special Layer.
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Alternatively, check the Use layer name prefix for Merge. This 
means that while merged IFC elements will remain on their respective 
separate layers, these layers will each get a uniform prefix. 

Miscellaneous Options

Keep IFC Global Unique IDs: This option affects the GUIDs of 
IFC elements that you plan to re-export from the ArchiCAD plan. As 
a rule, this box should remain checked, to maintain a consistent 
model if you are using other IFC-based tools. 

However, if you plan to use the exported IFC file as a separate, 
duplicated model, you can uncheck the box: the exported elements 
will gain new IFC GUIDs.
Always show Project Data dialog before Open: The displayed 
Project Data dialog gives you information on the building hierarchy 
of the imported IFC file (which might contain multiple buildings).
Show Options before Save: By default, the IFC Options dialog box 
is displayed when you Save an ArchiCAD file as IFC.
Show IFC library selection before Load: When opening an IFC 
file in ArchiCAD, this option means that the location of the IFC 
default library will be displayed.
Show EDM database dialog before Save and Load: This option 
displays and gives you access to an internal database used when 
exporting to IFC.
Activate notification of changes: If the IFC add-on is running in 
ArchiCAD, this option will send all project modifications to the IFC 
data buffer of ArchiCAD at once. (This will slow down the program.) 
Show localized IFC keywords: This option affects the language (as 
shown on the interface only) of IFC keywords (properties, attributes, 
etc.)

Special Options
This button, on the Miscellaneous page of IFC options, gives you 
access to a set of custom functions (often in “test mode”) that may 
vary depending by release and language version.
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Special Options may include:
IFC GUID’s of selected elements: This command enables 
ArchiCAD Report to display IFC GUID’s.
Update with custom PSET: Updates the ArchiCAD file based on a 
chosen ifc configuration file.
Update properties: Updates the ArchiCAD file by updating the 
parameters of all IFC properties.

Merge IFC to ArchiCAD
To merge the IFC model to the current ArchiCAD file, use this 
command:

File > File Special >Merge

Important: You should save the ArchiCAD file before merging 
an IFC file.

Use the appearing IFC Merge dialog box to filter the elements to be 
merged.

In the top left window (labeled “Containment Structure”), IFC 
entities are listed one by one. (Their properties and attributes are 
displayed at the right.) Check/uncheck the boxes depending on 
whether you want to merge them.

To make this process easier, filter the contents of this window using 
any of the filters below:

• by history (i.e changed elements only, or all elements)

• by layer or owner
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• by engineering domain. You can select among 2 predefined 
engineering domain filters (Structural and HVAC) or create your 
own filter using the “Edit user defined filter” button.

Click OK to execute the Merge process.
Note: The Special Layer preferences you set in the Import page 
of IFC Options will affect the Merge process. (See Import 
Options.)
Note: The Merge function deletes the original ArchiCAD 
element if it has the same GUID as the merged IFC element.

IFC Tree View
The IFC Tree View provides a hierarchical overview of the current 
project’s IFC model database. Use the Tree View dialog box to access 
model information, and to edit and update the entire ArchiCAD 
project.
To open Tree View, go to File > File Special > IFC 2X3 > Tree 
View.

The left side displays the IFC model hierarchy (Containment 
Structure) listing IFC entities one by one (classified according to 
element type). Use the two tree-view icons above this window to 
open or collapse the hierarchy display.
The right side of the dialog box displays the attributes and properties 
of any element you have selected on the left. (Alternatively, click the 
pop-up to display Element Types with their properties. (See also 
Create New Property.) As in the Tool Settings dialog boxes, here too 
you can create a New Property or Property Set. (See Create New 
Property.)
14 IFC 2x3 Reference Guide for ArchiCAD 12



ArchiCAD IFC 2x3 Guide
To locate a specific element in the hierarchy more easily, you can use 
the Search function, just below the tree structure window: enter the 
element’s IFC GUID (or any portion of it) in the text field, then click 
Search. Clicking any item in the Search results window will show you 
that element’s location in the tree view.
Use the Grouping Information section (below left) to create IFC 
Groups and IFC Zones as needed. IFC Groups and IFC Zones are 
optional classifications that serve to further classify your elements in 
IFC.
To create an IFC Group or an IFC Zone:
1) Select the folder you need under Grouping Information (e.g. 

“IFC Groups”). 
2) Click the New Group/Zone button.
3) Give a name to the new Group or Zone.
The newly created Group/Zone folder appears in the list. Now, click 
any one or more entities in the Containment Structure hierarchy 
above. Drag and drop them into the Group/Zone folder you have 
created below.

Note on Spaces and Zones: In IFC Tree View, an ArchiCAD 
Zone (usually, an individual room) is listed in the Spaces 
category. One or more such spaces can be grouped in an IFC 
Zone (usually, a set of multiple spaces), which should not be 
confused with an ArchiCAD zone. 

The Tree View dialog box is a modal dialog box; you can keep it open 
while working in the model. If you add, delete or modify elements in 
the model, press the Synchronize to plan button to refresh the tree 
dialog.
Select in plan: Select one or more entities in the tree view hierarchy, 
then click the Select in Plan button to select and zoom to that entity 
in the ArchiCAD model window.
Select in Tree: Click this to find any selected model elements’ 
location in the Tree View hierarchy.
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Structural-Related IFC 
Features
Structural models are simplified versions of architectural models – 
containing only load-bearing elements such as columns, beams, slabs 
and walls. In case of composite structures (such as multi-layered walls, 
slabs etc.) only the structural component – for instance the 
reinforced-concrete core – should be considered as load-bearing 
element. Structural applications will use the structural model as the 
main information input to define the analytical model to be used 
through the analysis and design calculations.
ArchiCAD advises IFC specific settings to help in main segments of 
the architectural-structural model exchange.

Layer Settings and Partial Structure Display

The Partial Structure Display function and the layer system in 
ArchiCAD allow you to display and output the load-bearing 
structural elements (simplified architectural elements).
As a first step, the load-bearing elements of an architectural model 
can be filtered out from the entire structure by using Layers and 
Layer Combinations (Document > Layers > Layer Settings).

The Partial Structure Display (Document menu) settings influence 
composite (Slab, Wall and Roof) and complex (Wall, Column and 
Beam) structures only. The load-bearing part of these elements is the 
Core skin.

Please note that the Partial Structure Display settings are view 
specific. The Partial Structure Display of the Floor Plan view will be 
considered when exporting an IFC file having the Floor Plan as the 
active view.
To save the “structural” elements considered in the simplified 
architectural model view, apply the following settings on the Export 
Options page of IFC Options:
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Export element

To consider the active layers (defined by a Layer Combination) of the 
current view, choose the “All visible” or “All visible on current story” 
option (depending on whether you would like to save visible elements 
on every story or only on the current story).

Follow Partial Structure Setting

Enabling this option saves composite and complex elements selected 
at Export element with their displayed state set at Partial Structure 
Display settings (it affects composite and complex structures only).

Enable Load-Bearing Property

Some structural software applications are able to differentiate 
between load-bearing (structural) and non-load-bearing building 
elements. To enable this type of differentiation of elements in model 
exchange, ArchiCAD enables architects to expand the basic elements 
properties to include load-bearing behavior.

If you show available sets of IFC attributes in the elements’ Settings 
Dialog (see IFC Panel in Tool Settings), the load-bearing feature can be 
added to new or selected structural elements.
The figure shows how the load-bearing option can be activated 
(“True” value) for walls at Pset_WallCommon/ LoadBearing:

Please note that the activation and modification of IFC attributes 
works only in Floor Plan views.
For more information on structural-related IFC features, see:

http://www.graphisoft.com/products/archicad/solutions/structural.html
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IFC Settings for Thermal 
Calculation
ArchiCAD with its Zone concept gives perfect input for thermal 
calculation software applications. Zones are 3D solids in geometrical 
aspect and in normal cases are bordered by two slabs and four walls.

ArchiCAD calculates the position and the size of elements that 
border Zones.
In practice, the structural elements (e.g. walls, slabs and roof), 
windows and doors all have different thermal conductivity properties. 
Therefore, ArchiCAD divides the zone boundaries according to the 
areas defined and cut by connected elements and openings.
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Space Boundaries:
01 - Wall part defined by Zone03
02 - Wall part defined by Zone02
03 - Wall part cut by connected wall
04 and 05 - Area defined by door opening

Space Boundaries:
01 - Slab part defined by Zone01
02 - Slab part defined by Zone03
03 - Slab part defined by Zone02
04 - Slab part without thermal convection

ArchiCAD can store Space boundaries (wall and slab parts) and their 
relations (IFCRelSpaceBoundary) together with the zones (IFCSpace) 
in IFC files. Just activate the “Save Space boundaries” option in the 
Export tab of the IFC saving dialog (Save as).
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The Tolerance between spaces means the maximum distance between 
neighboring zones or - in other words - the thickest wall/slab.

Note: Space boundary calculation in ArchiCAD only works if 
you have placed the zones using Inner Edge definition method.
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IFC Settings for Quantity 
Takeoff
To provide Quantity Takeoff parameters (for example for cost 
estimation applications), ArchiCAD calculates quantities of the 
following elements: Wall, Column, Beam, Slab, Roof (slab) and Zone.
Activate the Area/Volume calculation option in the Export tab of the 
IFC Options dialog (after you have done a File > Save as IFC).

For example, in the case of walls, the following quantities 
(IFCElementQuantity) will be saved in IFC files:
• Height,
• Perimeter,
• Gross volume,

• Net volume (volume reduced e.g. by columns embedded into the 
wall),

• Gross Floor Area (doors are not considered),
• Net Floor Area (area reduced by door footings),
• Gross Wall Area (openings are not considered),
• Net Wall Area (area reduced by openings).
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